More on Connection Lifetime Expired for Transproxy access

From: Richi Plana <>
Date: Sun, 24 Oct 1999 13:18:22 +0800 (PHT)


Several days ago, I reported having problems accessing a transparent proxy
cache system I set up using transparenty proxying but not when using it as
a regular proxy. Well, today I re-installed the machine from scratch, set
up Squid and upgraded to the latest stable Linux kernel (2.2.13).

As soon as I applied the ip policy to my Cisco router, I was delighted to
see that it worked. I left it chugging along for a couple of hours letting
my users use it. When I came back, I found to my chagrin that it was again
exhibiting the same behavior as before: regular use of the proxy would be
fast but accessing it transparently would result in the "Connection
Lifetime Expired" page.

As soon as I found out, I removed the ip policy route-map configuration on
my router. After a couple of hours, I re-applied it and found that
transparent proxying was working again! (argh)

To isolate the problem, I tried immediately redirecting from a different
router (diff. model and CIOS) and it still exhibited that same symptom (so
it's probably not a router issue).

A couple of questions:

1) Is this a Squid issue or a Linux kernel/ipchains issue?
2) How does one go about finding out?
3) If it's Squid starving for resources, which should I look to first?

4) Any one else experiencing this?
5) Shouldn't this be addressed to the developer's list?

L L Richi Plana 8^) ,-,-. ,-,-. ,-,-. ,-,-. ,-
LL LL Systems Administrator / / \ \ / / \ \ / / \ \ / / \ \ / /
LLLLL Mosaic Communications, Inc. \ \ / / \ \ / / \ \ / / \ \ / /
LLLLL `-'-' `-'-' `-'-' `-'-'
Received on Sat Oct 23 1999 - 23:25:26 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:49:03 MST