[SQU] httpd_accel and cache_peering problem

From: Thimal Jayasooriya <thimal@dont-contact.us>
Date: Fri, 19 Jan 2001 21:11:43 -0800

Hi all:
     Thanks to Squid, I've finally gotten some of the huge
performance problems of my webserver sorted out.... I've just
inserted httpd_accel host and httpd_accel_host directives and it
works fine..

   My next job is to setup a secondary cache to swap data ICP
(well, just to swap cache data)...Unfortunately, this simply never
happened.. when I setup another machine and put in
"cache_peer machine.foo.com parent 80 3130"
into the conf file, I saw no exchanges happening...In fact the
caches were not communicating with each other at all...I've
designated the primary cache as the parent, and the second
machine as the sibling... from what I understood, this means that
when a request goes to the sibling, it will ask the parent first via
ICP, right ? All I seem to be getting is an error page from the
sibling...saying "MISS/400" : Bad request

        I'm running RedHat 7.0 on both machines and I've tried
recompiling from source with --enable-htcp, enable-carp-digest and
so on.... with no luck..
I do know that each machine "sees" and configures the other as a
sibling.. (that from looking at output of -NCd1), but they simply will
not exchange any data!!

I've tried to put in as much info as I think is relevant... has anyone
tried this setup ? reverse proxy with cache peering thrown in ? The
FAQ didn't seem to help here, and I've also tried the Hierarchy
tutorial... any info or help on how to sort this out is greatly

Thanks in advance,

To unsubscribe, see http://www.squid-cache.org/mailing-lists.html
Received on Fri Jan 19 2001 - 22:15:52 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:57:30 MST