[SQU] being driven nuts by a forwarding loop

From: Brett Lymn <blymn@dont-contact.us>
Date: Mon, 22 Jan 2001 14:54:55 +1030 (CST)

        I have a squid proxy server sitting on port 80 of my machine.
I have an apache web server sitting on port 81 of the same machine. I
want to be able to use the httpd accelerator in squid and make it talk
to apache when I put the url http://proxy/. Easy, but I keep getting
a forwarding loop message in cache.log. Now, before you hit the
faq-o-matic button I have been there done that and I STILL get this
bleeding forwarding loop. I am running Squid 2.4 PRE-STABLE in a
Solaris 2.7 box. Here are some snippets from my squid.conf:

httpd_accel_host saproxy.baea.com.au
httpd_accel_port 81
httpd_accel_single_host on
httpd_accel_with_proxy on
http_port 80
redirect_rewrites_host_header off

I get this in the cache.log:

2001/01/22 14:44:42| WARNING: Forwarding loop detected for:
GET / HTTP/1.0
User-Agent: Mozilla/4.72 [en] (X11; I; SunOS 5.6 sun4m; Nav)
Pragma: no-cache
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, image/png, */*
Accept-Encoding: gzip
Accept-Language: en
Accept-Charset: iso-8859-1,*,utf-8
Proxy-Authorization: Basic XXXXXXXXXXXXXXXXXXXX
Cookie: SITESERVER=ID=13a27cefde03548575dfadd9e21cb8d7
Via: 1.0 saproxy:80 (Squid/2.4.PRE-STABLE)
Host: saproxy.baea.com.au
Cache-Control: max-age=259200
Connection: keep-alive

I have tried setting httpd_accel_host to localhost but I get the same
thing. Any suggestions?

Brett Lymn, Computer Systems Administrator, BAE SYSTEMS
To unsubscribe, see http://www.squid-cache.org/mailing-lists.html
Received on Sun Jan 21 2001 - 21:28:33 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:57:31 MST