[squid-users] More WCCP woes

From: Curtis E. Hays II <hays@dont-contact.us>
Date: Tue, 13 Mar 2001 17:28:35 -0600

Apparently I'm not trying enough to get wccp working.... any help would be
appreciated.. here are my current non-working configs...

Cisco router config:
ip subnet-zero
ip wccp version 1
ip wccp web-cache
interface FastEthernet0/0
 ip address
 ip broadcast-address
 ip wccp web-cache redirect out
 duplex auto
 speed auto

(relevant parts)

running ios: IOS (tm) 3600 Software (C3640-I-M), Version 12.1(1)T,

I've compiled my Linux kernel ver 2.2.18 with the ip_wccp.c patch... I'm
running squid 2.4PRESTABLE2 in http accel mode... I've got a windows box
with a default gw of the cisco router and the squid on the same segment.
The cisco config doesn't show any way to communicate with the squid i.e.
don't configure an IP??? is it a broadcast protocol that they are
to see each other? The cisco doesn't show it:

wccp-rtr#sh ip wccp
Global WCCP information:
    Router information:
        Router Identifier:
        Protocol Version: 1.0

    Service Identifier: web-cache
        Number of Cache Engines: 0
        Number of routers: 1
        Total Packets Redirected: 0
        Redirect access-list: -none-
        Total Packets Denied Redirect: 0
        Total Packets Unassigned: 0
        Group access-list: -none-
        Total Messages Denied to Group: 0
        Total Authentication failures: 0

I've got IPCHAINS configured on the linux box to redirect port 80
traffic to
port 3128, but it doesn't look like the cisco even sees the wccp enabled
linux box/squid....

I didn't get the mention of configuring a GRE tunnel on the Linux box,
so I
configured a GRE tunnel up... no ip or anything... just up... then with
IP on the same network. using :

        iptunnel add gre1 mode gre remote <Router-IP> local <Host-IP>
        ifconfig gre1 up

  still didn't see anything on the cisco when doing 'sh ip wccp'

so I tried building the other end of the gre tunnel on the cisco with :

interface Tunnel0
 ip address
 ip broadcast-address
 tunnel source FastEthernet0/0
 tunnel destination

nothing working yet :(

so I tried this:

interface Tunnel0
 ip address
 ip broadcast-address
 tunnel source FastEthernet0/0
 tunnel mode ipip decapsulate-any

Still no cache engine showing up with 'sh ip wccp' on the router.

ANY help would be appreciated... I've been goveling over the mailing
archives and can't seem to find the question or answer previously

Curtis Hays
Received on Tue Mar 13 2001 - 16:27:18 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:58:38 MST