[squid-users] Squid and Disk Space

From: Mike Diggins <diggins@dont-contact.us>
Date: Sat, 24 Nov 2001 09:27:51 -0500 (EST)

I'm running Squid (A proxy Server) on Solaris 2.8 on an Ultra 10. After
about a month of operation, both the OS and Squid began reporting my cache
files systems were full even though there was plenty of free space and
inodes. Searching the Squid FAQ revealed that the Solaris OS was prone to
fragmentation and that this could be the result. Running fsck -n {file
system} revealed a ridiculously high fragmentation percentage (millions!).

One solution, according to the FAQ, was to newfs the file system and
optimize for space instead of time, so I did the following:

        newfs -o space -m 5 /dev/dsk/c2t0d0s4
        newfs -o space -m 5 /dev/dsk/c2t1d0s4

It ran for another month but today I got the same error. I suspect file
fragmentation was the problem again! Does anyone know how I might resolve
this more permanently? According to the FAQ, optimizing for space was
supposed to be a solution but it doesn't seem to have worked for me.

Any help appreciated!

Received on Sat Nov 24 2001 - 07:27:53 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:04:29 MST