[squid-users] winbind/PAM problem - pam_auth

From: Noel Kelly <nkelly@dont-contact.us>
Date: Sat, 2 Feb 2002 09:41:51 -0000


I wonder if anyone could tell me if Henrik Nordstrum's pam_auth module works
with the Samba winbindd program ? I seem to be half way there but it just
won't bite.

I have squid referring to pam_auth with in squid.conf:

authenticate_program /etc/squid/pam_auth

My ACL setup is like this:

acl ukinternet proxy_auth REQUIRED
http_access allow ukinternet

I also tried defining an explicit group: acl ukpassword proxy_auth
uk+"domain users"

Then, I have a pam module file called 'squid' which looks like this:

cat /etc/pam.d/squid
auth required /lib/security/pam_winbind.so
account required /lib/security/pam_winbind.so

The browser throws up the authentication box and I enter my details so
that this appears in the syslog:

Jan 31 15:22:29 manila pam_winbind[15891]: user 'uk+nkelly' granted access

But then the authentication box pops up again as if Squid was not happy with
the result from winbindd. Am I missing something here ?

I saw also that there is a trial winbind authenticator helper by 'kinkie' in
the Squid CVS but I don't seem to have got a 'configure' script with the
source. Is there a way I can extract just the helper or does it require a
full compile ?

Besides, I thought PAM modules were pluggable so that a common result was
returned to the requesting program. Any pointers greatly appreciated,

Noel Kelly
Received on Sat Feb 02 2002 - 02:42:11 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:06:09 MST