[squid-users] Transparent Proxies + Problems

From: neil d. quiogue <neil@dont-contact.us>
Date: Mon, 4 Feb 2002 14:17:37 +0800 (HKT)


This was raised before (after searching the archives) but I haven't seen a
good resolution to the problem.

There was a problem before that squid acting as a proxy/cache for a
redirector (like an L4 switch) to provide transparent proxying. There had
been problems wherein users are not able to access some services like the
LiveUpdate from McAfee (and some online games). Aside from configuring
the L4 switch, is there anyway to configure it in Squid instead? My worry
is that we would then have to keep track of these sites regularly and
update the L4 switch.

As an aside, I'm seeing a Forwarding Loop (changed some information
2002/02/04 14:06:30| WARNING: Forwarding loop detected for:
POST /ECom/Pull/EcomPullDLL.dll?140QueryProductInfo HTTP/1.0
Content-Type: application/x-mcafee-ec-1*da4da4cc-1385cb1f-cf44d416
Content-Length: 512
Via: 1.0 unique.hostname.at.isp:80 (Squid/2.4.STABLE3)
Cache-Control: max-age=259200
Connection: keep-alive

1. In order to simplify things, I didn't configure any hierarchy yet I'm
still seeing a forwarding loop. Why is that?

2. is a non-existent address (not configured in L4 switch)
or the proxy server. So why am I getting it? Or maybe I don't understand
what X-Forwarded-For means.

Maybe someone can clear this up? Much thanks.

Neil D. Quiogue
         "Nothing great was ever achieved without enthusiasm."
                                             - Ralph Waldo Emerson
Received on Sun Feb 03 2002 - 23:17:40 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:06:09 MST