[squid-users] DNS lookup errors when using squid

From: Oliver Marshall <Oliver.Marshall@dont-contact.us>
Date: Thu, 3 Apr 2008 14:03:09 +0100

We run a very basic squid setup on a windows 2003 box here. It's purely
used to route all web traffic over a cheap adsl line leaving the leased
line free for important stuff. The 'squid server' (win2k3) has the
gateway IP set to that of the adsl router meaning that when someone sets
the proxy in their browser all the web traffic will go over the adsl
line. If for some reason the adsl goes down, we just change the gateway
address to the leased line router and the web comes back. It's a basic
but workable solution.


We have been having a lot of problems with people getting DNS lookup
failures when using the squid proxy. If we remove the proxy setting, the
web works for the users, put them on to squid again and with an hour or
so DNS failures appear. Hitting F5 a few times solves it and they carry
on until the next time, but it only happens with Squid. I've tried
swapping from the ADSL to the SDSL but it still happens if squid is
used. I've tried another Windows proxy, and the problem doesn't happen,
nor does it happen without Squid involved at all.

Any ideas why this might be? I know that squid doesn't have a DNS
element as such, using the DNS settings and servers specified on the
underlying OS, but the fact that it only happens with Squid involved
does make me think something is wrong somewhere.

Received on Thu Apr 03 2008 - 07:03:48 MDT

This archive was generated by hypermail 2.2.0 : Thu May 01 2008 - 12:00:04 MDT