RE: [squid-users] Unable to access a website through Suse/Squid.

From: Terry Dobbs <>
Date: Thu, 3 Apr 2008 12:36:03 -0400

I tried adding the first route, but it didn't seem to make a difference.
The ethereal capture still shows my squid box sending window size of
1460? Do I need to restart networking to take effect, when I do this it
wipes out the route?

Also, the second command gives me an error and says "mss" is a garbage.

-----Original Message-----
From: Henrik Nordstrom []
Sent: Wednesday, April 02, 2008 7:44 PM
To: Terry Dobbs
Subject: RE: [squid-users] Unable to access a website through

ons 2008-04-02 klockan 15:43 -0400 skrev Terry Dobbs:
> Ok folks, here is my packet capture; I included only the transmissions
> between the 2 relevant devices (SUSE Server and the problematic
> website).

The capture looks very much like the issues seen by window scaling, but
there is no window in scaling in this trace... A bit confused..

Guessing wildly here, but my first action would be to upgrade the kernel
just in case it's a known tcp problem which has been worked around

Another thing you can try is to decrease the window size to a very small

  /sbin/ip route add via your.internet.gateway window 1480

this isn't optimal for performance, but may work around certain broken
firewalls if there is packet reordering at play..

You can also try lowering the MSS, in case there is a MTU blackhole...

  /sbin/ip route add via your.internet.gateway mss 496

Received on Thu Apr 03 2008 - 10:36:51 MDT

This archive was generated by hypermail 2.2.0 : Thu May 01 2008 - 12:00:04 MDT