[squid-users] COSS problem on Squid 2.6.Stable19

From: da duy <d4duy@dont-contact.us>
Date: Fri, 4 Apr 2008 01:06:47 -0700 (PDT)

Dear Squid-Users,

I'm currently having problem installing squid on Ubuntu 7.10, i;ve compiled them with this option:

sudo ./configure --enable-storeio=coss,ufs,aufs,diskd -with-large-files --enable-delay-pools --enable-snmp --enable-removal-policies=heap,lru --enable-auth=ntlm,basic --enable-external-acl-helpers=ip_user,ldap_group

i create the cache file first with these command:

sudo dd if=/dev/sda bs=1048576 count=5000 of=/usr/local/squid/var/cache

and i add these line to squid.conf:

cache_dir coss /usr/local/squid/var/cache 5000 block-size=512 max-size=524288
cache_swap_log /usr/local/squid/%s

when i run sudo squid -k parse everything is fine, but when i run sudo squid -z i get this:

2008/04/04 21:46:04| Creating Swap Directories
FATAL: Failed to create COSS stripe /usr/local/squid/var/cache
Squid Cache (Version 2.6.STABLE19): Terminated abnormally.
CPU Usage: 0.010 seconds = 0.000 user + 0.010 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0

i've tried googling but could not get an explanation of the case, any help would really be appreciated,

thank and regards,

You rock. That's why Blockbuster's offering you one month of Blockbuster Total Access, No Cost.
Received on Fri Apr 04 2008 - 02:06:57 MDT

This archive was generated by hypermail 2.2.0 : Thu May 01 2008 - 12:00:04 MDT