[squid-users] Squid 3.1 rejecting connections after few thousands requests

From: <alteriks_at_gmail.com>
Date: Fri, 21 May 2010 16:29:33 +0200

Hi, I've run into problems after upgrading 3.0.STABLE19 (installed from packages) to squid 3.1
I'm running amd64 8.0-RELEASE FreeBSD, with squid as accelerated proxy.

3.0.STABLE19 runs almost flawlessly. I'm getting 'Select loop Error' every second:
2010/05/21 14:37:34| Select loop Error. Retry 1

and these errors once in a while in my cache.log:
2010/05/21 14:39:14| comm_old_accept: FD 14: (53) Software caused connection abort
2010/05/21 14:39:14| httpAccept: FD 14: accept failure: (53) Software caused connection abort

I've never ran in such problems on Debian Squeeze (also with squid3.0), so I really don't know if I could ignore them.
I have successfully tested 3.0.STABLE19 on FreeBSD with 2500hits/s

After a while I tried to upgrade to the newest version of squid I've tried squid-3.1.3 from ports, and squid-
from packages. Both versions after handling few thousands of requests are stopping serving on specified port.

Here is my configuration squid listens on 2 ports:

netstat -an |grep LISTEN
tcp4 0 0 *.8080 *.* LISTEN
tcp4 0 0 *.80 *.* LISTEN

'All' request goes to :8080, I configured port :80 only for testing. After few thousands of requests to :8080, squid stops
handling requests coming from that port. If I telnet to :8080 my connection is closed instantly, but If i send request to
:80 everything is fine.

Here are excerpts from cache.log, after I saw that squid doesn't serve anything I stopped it:
2010/05/20 12:09:56| Preparing for shutdown after 7460 requests
2010/05/20 13:00:19| Preparing for shutdown after 8843 requests
2010/05/21 14:10:37| Preparing for shutdown after 9963 requests

While trying two 3.1 versions of squid I also saw 'Select loop Error. Retry 1'
Received on Fri May 21 2010 - 14:29:42 MDT

This archive was generated by hypermail 2.2.0 : Mon May 24 2010 - 12:00:05 MDT