[squid-users] 401 Unauthorized

From: zongo saiba <zongosaiba_at_gmail.com>
Date: Sat, 22 May 2010 12:33:09 +0100


I am using Squid Version 2.7.STABLE7 with Ubuntu 10.04. Everything seems
to be working fine but I have one issue which is to be able to pass on
the credential windows to squid for one of my remote site.
I have tried using cache_peer as such:

cache_peer hostname sibling 80 0 login=PASS

But to no avail.

I added this line --> cache_peer_access hostname allow all --> but to no

Finally I tried this --> never_direct deny all --> Again, to no avail.

I decided to tried to create an acl for this particular domain as such:
acl xxx dstdomain domainname.com
http_access allow xxx
But again all this to no avail.

Then I realised that this might have something to do with HTT header. As
per doc, basic authentication seems to use the WWW-Authenticate HTTP
Header. I have that disable for security reasons. So I did find out why
the credentials window is not passed on the my browser. I decided to try
to create a customer HTTP header for this site as such:

acl cdnCustomHeader req_header ^domainame.com
http_access allow cdnCustomHeader

This had the effect of reporting the 401 error on all the websites I was

I did try with this as well but again to no avail

header_access WWW-Authenticate allow hostname.

I have run out of idea here and would appreciate any help.

Kind Regards,


zongo saiba
http://zalloc.blogspot.com/ (Mac OS X)
http://zongosaiba.blogspot.com/ (Linux)

Received on Sat May 22 2010 - 11:33:20 MDT

This archive was generated by hypermail 2.2.0 : Sun May 23 2010 - 12:00:32 MDT