Re: Problem with local_ip and local_domain in 1.0.7

From: Duane Wessels <wessels>
Date: Wed, 14 Aug 96 09:15:54 -0700 writes:

>I've just installed squid-1.0.7 and I can't seem to get local_ip or
>local_domain to work correctly.
>My conf file contains:
>[I've also tried]
>config is otherwise fairly normal (no parents or peers yet).
>The local IP stuff is intended to catch virtual servers to save me
>listing all the domains.
>Yet, neither seems to work. When I access,
>the stuff seems to be cached and returned with TCP_HITs later.
>Similarly, if I try a virtual web server, the local_ip stuff doesn't
>kick in. In fact, every line in hierarchy.log contains DIRECT. I've
>tried turned up the debugging in cache_cf.c, to catch the ip matching
>for local_ip, but I don't see anything turning up.
>Any ideas where I should look for the problem?

I think you might be confused about what local_domain/local_ip is.

It tells the cache "do not use neighbors for these domains/addresses."

Since you have no neighbors, local_domain/local_ip doesn't do anything
for you. Every line in herarchy.log should be DIRECT.

Duane W.
Received on Wed Aug 14 1996 - 09:15:55 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:32:48 MST