Re: Slow response from Squid beta 23...

From: Walter Klomp <>
Date: Fri, 6 Dec 1996 12:58:05 +0800

First of all, thanks for all your responses so far... :-) ... but not much
improvement yet... :-| I think I need more help...

> > Why does it still take 2-5 seconds before I get actually a response
from my
> > proxy server?
> There can be many reasons. Since it took me two months to tune my
> Alpha/DU machine to get a reasonable response time, I'm hardly a good
> consultant but let's try:

I tried all your suggestions... still not very much improvements... please
read on...

> I agree with Jonathan Larmour on the tuning of refresh_pattern. Default
> options render the cache less efficient: it always have to check the
> validity of files with the remote Web server.
I did jonathans changes, Thanks Jonathan, I think it's a matter of time
before the functionality kicks in, right?

> > default settings, what can I do to improve the response time?
> Check the following:
> - what malloc is used by SCO (or switch to a better operating system,
> does anyone use SCO here?). Most malloc shipped with commercial Unix are
> inefficient or broken (a colleague showed me a paper in Usenix 1986
> describing a bug in malloc, bug which is still present in Digital Unix).
> May be you can try GNU malloc.
> - check paging. I know you have 192 Mb but Squid can eat a lot more quite

> easily. Look at it with ps, use vmstat.

No, only 30% of the memory is used... no swapping activity, CPU load around
40%, Diskload around 20%
> More info:
> cachemgr's "info" should tell you interesting things. Post it here.

O.K... here it comes... hmmm... it just restarted... no error in the
squid.out... no panic... :-\

dated Fri Dec 6 12:50:56 1996

Squid Object Cache: Version 1.1.beta23
Start Time: Fri, 06 Dec 1996 04:44:43 GMT
Current Time: Fri, 06 Dec 1996 04:53:23 GMT
Connection information for squid:
        Number of TCP connections: 1346
        Number of UDP connections: 14
        Connections per hour: 9415.4
Cache information for squid:
        Storage Swap size: 920 MB
        Storage Mem size: 10292 KB
Memory usage for squid via mallinfo():
        Total space in arena: 24908 KB
        Ordinary blocks: 24647 KB 162186 blks
        Small blocks: 39 KB 5760 blks
        Holding blocks: 1 KB 180 blks
        Free Small blocks: 54 KB
        Free Ordinary blocks: 260 KB
        Total in use: 24688 KB 99%
        Total free: 314 KB 1%
File descriptor usage for squid:
        Max number of file desc available: 3000
        Largest file desc currently in use: 60
        Available number of file descriptors: 2939
        Reserved number of file descriptors: 100
Internal Data Structures:
         73180 StoreEntries
          1128 StoreEntries with MemObjects
          1128 StoreEntries with MemObject Data
          1114 Hot Object Cache Items
Accounted Memory Usage:
        StoreEntry 73180 x 52 bytes = 3716 KB
        URL strings = 3450 KB
        IPCacheEntry 90 x 36 bytes = 3 KB
        FQDNCacheEntry 0 x 56 bytes = 0 KB
        Hash link 1114 x 12 bytes = 13 KB
        Pool MemObject structures 1128 x 92 bytes = 101 KB ( 0 free)
        Pool for Request structur 60 x 4520 bytes = 264 KB ( 88 free)
        Pool for in-memory object 3208 x 4096 bytes = 12832 KB ( 0 free)
        Pool for disk I/O 18 x 8192 bytes = 144 KB ( 56 free)
        NetDB Address Entries 0 x 72 bytes = 0 KB
        NetDB Host Entries 0 x 8 bytes = 0 KB
        ClientDB Entries 40 x 160 bytes = 6 KB
        Miscellaneous = 2898 KB
        Total Accounted = 23429 KB

Generated Friday, 06-Dec-96 04:50:56 GMT, by

> echoping can tell you if the problem is remote or local. Look at this
> trace to a specific Web server:

I downloaded it, compiled it and got the following errors... maybe somebody
can help me ? I am not too strong in C programming...

#gcc -c -O3 -DHTTP -Wall echoping.c
echoping.c: In function `main':
echoping.c:303: warning: implicit declaration of function `bzero'
echoping.c:599: warning: int format, long int arg (arg 2)
echoping.c:599: warning: int format, long int arg (arg 3)
echoping.c:55: warning: `sp' might be used uninitialized in this function
echoping.c: In function `printstats':
echoping.c:635: warning: int format, long int arg (arg 2)
echoping.c:635: warning: int format, long int arg (arg 3)
echoping.c:637: warning: int format, long int arg (arg 2)
echoping.c:637: warning: int format, long int arg (arg 3)
echoping.c:640: warning: int format, long int arg (arg 2)
echoping.c:640: warning: int format, long int arg (arg 3)
echoping.c:676: warning: int format, long int arg (arg 2)
echoping.c:676: warning: int format, long int arg (arg 3)


undefined first referenced
 symbol in file
ntohs echoping.o
inet_addr echoping.o
gethostbyname echoping.o
getservbyname echoping.o
socket echoping.o
htonl echoping.o
htons echoping.o
bind echoping.o
inet_ntoa echoping.o
connect echoping.o
send echoping.o
recv echoping.o
ld fatal: Symbol referencing errors. No output written to echoping
make: *** [echoping] Error 1
Received on Thu Dec 05 1996 - 21:15:18 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:33:49 MST