To be continued: Squid performance on AIX

From: Rodney van den Oever <>
Date: Thu, 12 Dec 1996 22:00:50 +0100

I run Squid on AIX 3.2.5 and have had major performance problems since
release 1.0.20, Squid stalls for a couple of minutes and then suddenly
works fine for a while, local access through Lynx often doesn't work.
Version 1.0.18 worked perfect, so I squid (sorry typo: skipped) the 1.0.2x
releases and tried 1.1.0, which did not work for me either.

I experimented with the number of dnsservers (up to 16) (the server is
already running named). Memory settings (the machine has 128Mb RAM/1Gb
cachedir), nothing showed up in my logs. Clean source instead of patches

Linux boxes did not have this problem (I built an internal hierarchy with
the AIX-box being the parent proxy for the Linux-boxes used at other

After checking the diffs between version 1.0.18 and 1.0.20 for AIX specific
changes I noticed the following:

Changes to squid-1.0.20 (November 2, 1996):

        - Fixed !firewall_ip bug (Hiroyuki Inoue).
        - Added memset(&sockaddr) fix to ftpget (Maurizio Menghini).
        - Fixed "Don't append error messages to partially delivered
          objects" bug.
        - Fixed wierd ipcache miss counting bug (Arjan de Vet).
        - Cleaned up some terminology of parents, siblings, and neighbors
          in squid.conf.

Changes to squid-1.0.19 (October 30, 1996):

        - Fixed virtual-host coredump bug (Aaron Hopkins).
        - Disabled storeDirClean() for Unixware.
        - Fixed protoDispatch() to check firewall_ip_list before
        - Added '!' condition feature for the 'firewall_ip' list
          (Hiroyuki Inoue).
        - Fixed BASE tag in ftpget output (broken since v1.0.10).
        - Added Martin's multicast code inside '#ifdef USE_MULTICAST'.
>>>> - Removing -lbsd for AIX (Joerg Schumacher). <<<<
        - Added "(Squid/version)" to Forwarded: header.
        - Don't append error messages to partially delivered objects.

Changes to squid-1.0.18 (October 7, 1996):

        - Added INADDR_NONE to cachemgr.c for Solaris.
        - Added checks to deal with Harvest Cached neighbors which don't
          handle Squid's ICP version 2.
        - Added file upload patch (Jan Niehusmann).

No parents are used, no firewall_ip or virtual hosting and it didn't occur
with ftp specifically.

So I undid this little 'lbsd' change and now it works fine with release
1.1.0! So I definitely need this library (I'm no programmer, so don't know
what it is used for).

Happely running Squid again, thought I let you all know!
Received on Thu Dec 12 1996 - 13:26:53 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:33:53 MST