Different things

From: Jordan Mendelson <jordy@dont-contact.us>
Date: Wed, 10 Sep 1997 12:07:36 -0400

I have tried and tried to make Squid do what I want it to, but for some reason,
it won't, so I figure I'll post.

The first option I am trying to get is:


The nlanr parent caches that I'm using are 9 and 15 hops away, so it makes
sense that anything which is less than 9 hops away, I should fetch myself. So,
what I did was enable ICMP via removing the # from -DUSE_ICMP in the Makefile,
then I changed:


to on.

I made sure the pinger program was in /usr/local/squid/bin as well.

Now, when squid starts, it says that the pinger program was started (actually,
ICMP socket opened). The pinger program is running and everything.

However, for some reason, I don't see ICMP requests going out. Everything seems
to be pulled from my parent caches.

I'm using Squid 1.1.16, which also seems to have a little problem seg faulting
when I kill it with SIGTERM, so I guess there are some bugs. I'm using Linux

Does anyone have this working?


Jordan Mendelson     : www.wserv.com/~jordy/
Web Services, Inc.   : www.wserv.com
Received on Wed Sep 10 1997 - 09:11:52 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:36:57 MST