Re: TCP Connection failures

From: Oskar Pearson <oskar@dont-contact.us>
Date: Thu, 30 Oct 1997 13:42:46 +0200

Hi

> >It's most likely a linux bug - up to 2.0.31 you can get "bind - address
> >already in use" from autobinds or binds to port zero, meaning you fail
> >connections which are meant to just come from random TCP ports.
> (...)
> >It's probably better to fix the network/machine/OS problems than to patch
> >squid to handle them.

> does that mean that upgrading to linux 2.0.(>31) will fix the problem?
Probably. There are known problems with 2.0.31 though for certain
network cards and there is a memory leak that nobody can/will find.

>I dont care if the problem is within the squid or linux code, but I have to find a solution. BUT remember: Someone (sorry I lost the name) wrote on this list he had the same problem (loosing TCP connection to his parent cache) on a svr4 machine, not linux! And also to mention: Im not talking about the famous "operation already in progress" bug (yes, I have this one too, and yes, I can live with that, at least for now).
I used to get this often - and whenever I actually tried to ping the
site from the cache server it actually was unreachable.... the error
message is a little 'inappropriate' but it's consistent - the remote
site was unreachable and all packets were simply being dumped by a router
somewhere.

> Upgrading all linux boxes would take me at least a day, but Im willing to do it if chances are that it will fix the problem.
I suggest you upgrade one first - if you hit the memory allocation
problem after a few days, then let us all know your setup/config and
we might be able to fix the problem (there have been about 4 reports of
this so far, and LOTS of installs that work fine). Otherwise upgrade the
other servers too.

> Is there anybody who could affirm this? I mean, who had the lost TCP connections before upgrading, and solved it by upgrading to linux 2.0.31++ ?
I don't run 2.0.30 on any of our servers.... because of the
memory swapout problems. I run 2.0.29 on them at the moment becuase
I haven't been here all night often enough since 2.0.31 came out to take
all the servers down.

> Again, thanks for any hint or comment.
> PS: Would this linux upgrade also solve the "operation already in progress" problems?
Try upgrade libc.... that's where the message is coming from, I think, not
the kernel.

Oskar

-- 
"Haven't slept at all. I don't see why people insist on sleeping. You feel
so much better if you don't. And how can anyone want to lose a minute -
a single minute of being alive?"				-- Think Twice
Received on Thu Oct 30 1997 - 03:46:15 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:37:22 MST