Re: Squid w/FreeBSD 2.2.5 DNS Fails

From: Jaye Mathisen <>
Date: Wed, 24 Dec 1997 02:15:18 -0800 (PST)

Hmmm, I run several proxy servers doing various things over 2.2.5, some
stock installs, some upgrades, and have 0 problems with anything remotely
like this.

I can't offer much more than that, other then "I don't see the problem".

On Wed, 24 Dec 1997, Robert Blayzor wrote:

> I'm seeing the same problem as in a previous post here by Carey Nairn.
> >We just upgraded a 2.1.6 box to 2.2.2-RELEASE and now have problems
> >running squid due to DNS failures. This is pretty wierd since DNS works
> >fine using nslookup etc. The resolv.conf, host.conf, etc. is exactly the
> >same as our old ones, pointing to our DNS server.
> >Recompiling squid under 2.2.2 didn't do any good either.
> >This is using squid-1.1.14 and squid-1.1.16.
> I however did not upgrade, but did a clean install of 2.2.5 then cvsup'd
> to 2.2.5-stable.
> I am running Squid-1.1.18 and I get the same thing. Apparantly it looks
> like FreeBSD 2.2.5 including -stable has a broken gethostbyname(). I am
> wondering if there are any fixes for this or if anyone else has the same
> problem and knows a work around.
> I have squid running as "nobody" and Apache running as "nobody", but I'm
> not sure if that makes a difference.
> --
> Robert Blayzor Telecon Communications
> MIS/Programmer/Admin Network Engineer 131 Enterprise Rd.
> Superior Net Services 518-762-3456 Johnstown, NY 12095
> "FreeBSD! Turning PC's into Workstations!"
Received on Wed Dec 24 1997 - 02:23:42 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:38:02 MST