Squid 1.2b19 on NLANR caches broken

From: Jordan Mendelson <jordy@dont-contact.us>
Date: Sun, 29 Mar 1998 14:16:03 -0500

I've been noticing a lot of problems with the NLANR caches and their version
of Squid. For instance:

www.onsale.com a popular auction house is always causing uc.cache or
pb.cache to give a 'Connection refused' message, however when I force my 1.1
server to get it directly, these don't happen.

www.cdnow.com is the same way.

The odd part is that I would have thought the retry patch would retry any
errored fetches from the parent caches, but it doesnt.

Microsoft's Active Setup for Outlook 98 caused all sorts of problems with
the Squid 1.2 servers. A parent server said a file it was downloading was
1.8 megs when in reality it was 2.1 megs. So, I opened it up to a site which
wasn't cached on one of the NLANR caches and tried getting it again. This
time i hit cancel to force an abort. I tried getting the file again from the
same place, low and behold the file was truncated on the NLANR cache.

GameSpy, a popular internet game server browser has a bug which makes it not
put the 'HTTP/1.0' after the 'GET /URL' request. Squid doesn't understand
this and forces an error. Unfortunatly, a lot of my users use this program.
Is there a way to disable this behavorior?

What is it with IIS servers which cause Squid to completely go haywire?


Jordan Mendelson     : http://jordy.wserv.com
Web Services, Inc.   : http://www.wserv.com
Received on Sun Mar 29 1998 - 11:19:17 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:39:29 MST