Re: squid, alpha, and memory

From: B. Richardson <>
Date: Tue, 14 Jul 1998 09:39:23 -0400 (EDT)

Maybe running out of physical memory?

Here's something I learned from trial and error (before I started watching
this list). First attempts at running squid I tried to tweak to use all
available memory (efficiently without swapping of course) out of the gate.
You can't do that because squid's memory requirements grows as the
cache grows. When my cache is empty my memory usage is pretty close to
what my cache_mem setting is but over time the process memory usage
seems to grow nearly proportional the disk usage by the cache as some
information is kept in memory for each object in the cache. In practice
I have to allow about 7 mb of memory for each GB of disk usage by the

On Tue, 14 Jul 1998, Kelly Prescott wrote:

> I have a question about a problem I am having with squid 1.1.21
> I run on an alpha pc164 with Linux. I am using the pre-built package with
> rh 5.1.
> I have looked at the FAQ regarding this, and cannot seem to find an
> answer.
> When I start squid, it will run fine until it gets near the maximum amount
> of memory I give it in the config file. It then dies with a segment
> violation. The kernel reports a memory violation. I can reset the
> virtual memory all I want to. It always happens when the virtual memory
> limit is almost reached.
> Is this my malloc library?? Do I need to obtain another one?
> Thanks in advance.
> Kelly Prescott
Received on Tue Jul 14 1998 - 06:39:13 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:41:06 MST