Can't Refresh with transparent proxy.

From: } <Bike@dont-contact.us>
Date: Tue, 21 Jul 1998 17:37:06 +0800

When I press the [Refresh] bottom on the browser, it will send out a
refresh request, right? Is the that request different based on whether
I specify the proxy in the browser?

The situation is:
I build up a transparent proxy system with squid 1.1.22 and ACEswitch
several days ago. There is a guestbook on a web site, and we can leave
some message on the guestbook. After pressing the [Refresh] bottom
on the browser (I.E. 4.0), the new message should be showed on the page.

When I specify the proxy in the browser, this function performs well;
but
if I don't specify the proxy, and let the switch redirect the HTTP
requests
(any request to port 80) to the squid box, the page is not refreshed.

What I guess is:
1. The browser only skip the cache of the local disk send a ordinary
HTTP
    request if you didn't specify the proxy in the browser. And It add
    something in the header of HTTP request, if I specify the proxy.

2. There something I miss something with the configuration of squid.

This is the second time for this question, please give me any
suggestion.

 <___
( ) ( )
Any comment, please [mailto:Bike@hgc.com.tw].
Because of the policy of my company, we use our Chinese name for sender.

I'm very sorry for the indiscriminate characters, if you can't see
Chinese.
Received on Tue Jul 21 1998 - 02:37:50 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:41:12 MST