Socksifying Squid

From: Andy Walden <>
Date: Tue, 5 Jan 1999 13:49:21 -0600 (CST)

I have been through the archives and tried a couple of different things to
socksify squid. The first thing tried is runsocks squid -sY, which results
in Squid never actually running and just returning me to a prompt after 15
seconds or so. The second thing I have tried is the compile line given by
Henrik in the archives env CFLAGS="-g -O2 -Wall -Dbind=SOCKSbind"
LIBS="-lsocks" ./configure and get the result, checking whether the C
compiler (gcc -g -O2 -Wall -Dbind=SOCKSbind -g)
then configure: error: installation or configuration problem: C compiler
cannot create executables. Which Henrik replied that socks was installed
incorrectly. I just did a make install and it worked, so I'm not sure what
the correct way is. Do I need a /etc/libsocks5.conf or any other config
file possibly to make this work? Surely there are others that
successfully have this running. Any help is appreciated. Thanks in

Andy Walden
System Administrator
MTCO Communications
Received on Tue Jan 05 1999 - 12:39:59 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:43:54 MST