2.3.STABLE2 - seg. fault on FreeBSD 4.0-RELEASE

From: Joao Pagaime <jpsp@dont-contact.us>
Date: Mon, 15 May 2000 17:14:58 +0100 (WEST)

Hello all

I've just configured a Dell PowerEdge 4400 with
FreeBSD 4.0-RELEASE, and was trying to set up squid 2.3.STABLE2,
only to find out that it just segment-faults at the
first HTTP access.

Did anyone had the same problem? And if so, is there any solution?


PS: additional information:

 - Didn't yet compile the kernel
 - Also tried 2.4.DEVELx with the same result
 - On both versions didn't pass any parameters to "./configure"
 - Couldn't find any core dump (but this could be due to
    miss configuration of the OS?)
 - Other services work fine (for what I can tell so far) on that
   machine (Bind,xntp, etc.)

# strings /usr/local/squid/bin/squid | grep STA
A fragment from /usr/local/squid/logs/cache.log 
2000/05/15 16:53:08| Starting Squid Cache version 2.3.STABLE2 for 
2000/05/15 16:53:09| storeLateRelease: released 0 objects
FATAL: Received Segment Violation...dying.
2000/05/15 16:53:55| storeDirWriteCleanLogs: Starting...
2000/05/15 16:53:55| WARNING: Closing open FD    7
2000/05/15 16:53:55|   Finished.  Wrote 0 entries.
2000/05/15 16:53:55|   Took 0.0 seconds (   0.0 entries/sec).
FCCN - Fundação para a Computação Científica Nacional - Tel: +351-218440100
On Mon, 15 May 2000, Chris Conn wrote:
> Hello,
> Myself as well as another squid user have emailed this list in the past
> that after a variable amount of time the Linux 2.2.x box running squid
> would stop responding and the TCP/IP capability of the machine seemed
> hung.  We were both using 3COM 3c905B cards, and I therefore changed to
> an Intel ExpressPro 100 to test to see if the 3com linux driver was at
> fault.
> However, once more the machine running squid was no longer accessible to
> the network.  I this time however got logs from the Intel NIC driver:
> May 13 22:16:29 cache kernel: eth0: Transmit timed out: status 0050 
> 0090 at 155314080/155314094 command 000c0000.
> May 13 22:16:29 cache kernel: eth0: Trying to restart the transmitter...
> I had hundreds of these in my /var/log/messages.  No errors were logged
> to squid.
> I have since changed my switch port to autodetect instead of forcing it
> to 100mbps FD.  I hope that the switch is at fault.  This problem
> usually does not occur in periods of high load, so I don't believe it is
> a congestion issue.
> Any ideas?  Squid 2.3.STABLE-2.
> Thanks in advance,
> Chris
Received on Mon May 15 2000 - 10:18:54 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:53:29 MST