[SQU] Problem getting PDF:s through squid (2.3-stable4)

From: Deja User <jarde@dont-contact.us>
Date: Fri, 9 Mar 2001 06:28:59 -0800
('binary' encoding is not supported, stored as-is)    Problem we are experiencing is that downloading
   of PDF files fails in NT using Netscape 4.61 or
   with PDF plugin or helper. If the link is to direct
   document on the server (Microsoft-IIS/4.0)
   then it works fine. But when the link is to an
   asp script which returns a javascript like:
   Redirected server xxx.yyy (also Microsoft-IIS/4.0) returns the
   document ok.
   Netscape shows the first slide and few others but
   then the file seems to corrupted. When I then reload
   the document Netscape gets something where mime type
   is set to multipart/x-byteranges instead of original
   application/pdf. Then I save to file and on the first lines I see:

   Content-Type: application/pdf
   Content-Range: bytes 310169-311348/332813

   - I've tried to use IE 4 (SP1) on the NT, works fine
   - I've tried to use Netscape on Solaris, works fine
   - I've purged the document from the cache, still
     problems with Netscape 4.61 in NT.
   - I've tried bypassing proxy, works fine
   - I've heard IE having similar problems on other NT:s.

   Similar symptoms as described in:
   Both without followups.

   Any ideas ?

   / Jarde

--== Sent via Deja.com ==--

To unsubscribe, see http://www.squid-cache.org/mailing-lists.html
Received on Fri Mar 09 2001 - 07:32:24 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:58:35 MST