[squid-users] Help with running 2 instances of squid

From: Chris Wilcox <not_rich_yet@dont-contact.us>
Date: Sat, 18 Oct 2003 18:39:24 +0100

Hi all,

As far as I can tell, I have followed everything I'm supposed to have to
make this work. I wish to run two instances of Squid on the same machine:
Squid/2.4.STABLE6 on Debian Woody stable.

I have squid.conf and squid2.conf with the relevant settings altered.

Squid.conf listens on port 3128 on the external IP. I have not altered the
PID file path for this one.
Squid2.conf listens on port 8085 on I have altered the PID file
path to be /var/run/squid2.pid I have created a different cache directory
etc, and specified these within the squid2.conf file, along with checkong
relevant permissions on these directories.

I have then copied the squid init.d script and called this squid2. I have
altered squid2 to have a different name string, and altered all relevant
entries within this script to point to the squid2 details eg cache directory
etc. This squid2 script is set to use 'squid2.pid' as I've specified in

Yet still, when I do 'squid2 start' it always returns 'Squid is already
running! Process ID 213'

I'm now lost. Am I missing something really obvious here? I've been trying
to get this going for a good few weeks now!

Major thanks for any advice and suggestions!



Use MSN Messenger to send music and pics to your friends
Received on Sat Oct 18 2003 - 11:39:25 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:20:32 MST