Re: [squid-users] SSH not working With Squid3.0

From: <Adam_at_Gmail>
Date: Thu, 6 May 2010 12:07:23 +0100

Ok I'll try and describe it the best I can.

I have a router LinkSys/Cisco

This is how it goes:

Internet > [ISP-Modem] <Router / Firewall> (LocalNetwork )

Local Network > Machine1 Machine2 Machine3 Machine4 Machine5 Machine6

Machine1 = SQUID3.0
Machine2= Mail-Server
Machine3= Webserver1
Machine4= Webserver2
Machine5=DSN server
Machine6= Other services (Chat server)

And 3 Windows Clients

In All There are 9 Machines

I can access these machines except via SSH
Even though I have forwarded requests to each machine's SSH port

Now for the errors
When I try internally to connect to any of the SSH servers I get this error

Let's say the only accessible SSH is the one running on the Squid's machine
it has a port number 2222, ok?

Now if I want to ssh machine on port 2224
ssh 2224

I get the following

connect to host port 2222: Connection refused

Do you see what I mean even though I do specify the port number of the
machine which in this case is the port 2224
But I get the error message replying with the Squid's port number 2222, and
that is regardless from which machine I am trying to send the SSH request

And from outside

I get "Network Error Connection refused" if I try with putty for example:

But if I turn off Squid's machine and unplug it from the network, I have
absolutely no problem accessing these servers.

Very strange


----- Original Message -----
From: "John Doe" <>
To: <>
Sent: Thursday, May 06, 2010 9:55 AM
Subject: Re: [squid-users] SSH not working With Squid3.0

> From: "Adam_at_Gmail" <>
>> Yes I have searched why but could not find why not in the log not
>> anywhere else.
>> Tried with Iptables, with router same thing.
>> How do I know?
>> Ok if I shut down the proxy machine and completely remove it from the
>> network and try again absolutely no problems in connecting to all my ssh
>> serversbut when I run the proxy server, the problem comes back how about
>> that?
>> I know it is the proxy server, what I don't know is why?
> ok, so it is not a squid problem, but a server problem...
> Tried ssh -v (or -vv, -vvv)?
> What's the denied message in sshd logs?
> If you don't describe your setup (topology, routing, iptables rules...),
> we can barely try to guess...
> JD
Received on Thu May 06 2010 - 11:07:55 MDT

This archive was generated by hypermail 2.2.0 : Thu May 06 2010 - 12:00:08 MDT