Re: [squid-users] Squid 3.2.10 not compilable under OpenBSD 5.2

From: Loc Blot <loic.blot_at_unix-experience.fr>
Date: Mon, 29 Apr 2013 14:39:29 +0200

You are right !
But this doesn't resolve the openbsd /usr/local/include/ldap.h
and /usr/local/include/sasl.h issue :)

-- 
Best regards, 
Loïc BLOT, Engineering
UNIX Systems, Security and Networks
http://www.unix-experience.fr
Le mardi 30 avril 2013 à 00:04 +1200, Amos Jeffries a écrit :
> On 29/04/2013 5:16 p.m., Loïc BLOT wrote:
> > Hello amos,
> > The command Line you give didn't work. It always tries to compile all helpers. I must disable compile in the makefile and disable Sasl check in the configure file.
> 
> Sorry. My bad memory I'm afraid. I did some digging into it today and it 
> turns out the magic helper name "none" should do what I was thinking "" did.
> 
> AMos
> >
> > Loic Blot
> >
> > Le 29 avr. 2013 à 03:11, Amos Jeffries <squid3_at_treenet.co.nz> a écrit :
> >
> >> On 29/04/2013 5:50 a.m., Loïc BLOT wrote:
> >>> Hi,
> >>> i cannot upgrade squid because my ./configure fails (cause : sasl)
> >>>
> >>> checking sasl/sasl.h usability... no
> >>> checking sasl/sasl.h presence... no
> >>> checking for sasl/sasl.h... no
> >>> checking sasl.h usability... no
> >>> checking sasl.h presence... no
> >>> checking for sasl.h... no
> >>> checking for sasl_errstring in -lsasl2... no
> >>> checking for sasl_errstring in -lsasl... no
> >>> configure: error: Neither SASL nor SASL2 found
> >>>
> >>> With squid 3.2.9 i haven't this problem
> >>>
> >>> cyrus-sasl is installed but i don't need SASL.
> >>>
> >>> Have you got an idea ?
> >> We merged in the patch used by OpenBSD ports for auto-detecting SASL and LDAP libraries presence in this release. So a bunch of helpers which use SASL are now attempting build when they did not earlier. But that means the configure *did* detect SASL existence at some point.
> >>
> >> The helpers using SASL are mostly Basic auth helpers. So if you build with --enable-auth-basic=""  (exactly that, empty string parameter) it should enable basic auth without building any of the helpers. Or you can explicitly list just the ones you want to use.
> >>
> >>
> >> To help me resolve the issue permanently could you please let me know what was the exact full ./configure command you used was? and can you also supply a list of the SASL header files you have installed with full paths?
> >>
> >> Amos
> 
Received on Mon Apr 29 2013 - 12:39:16 MDT

This archive was generated by hypermail 2.2.0 : Mon Apr 29 2013 - 12:00:06 MDT