Re: [squid-users] ADVANTAGE OF UPDATE SQUID3.1 or newest

From: IT Support <it.compilation_at_gmail.com>
Date: Fri, 04 Oct 2013 10:38:44 -0500

Amos thanks for your answer Ill check it.

This is my output for squid3 -k parse

Processing Configuration File: /etc/squid3/squid.conf (depth 0)
Starting Authentication on port 0.0.0.0:14348
Disabling Authentication on port 0.0.0.0:14348 (interception enabled)
WARNING: use of 'override-expire' in 'refresh_pattern' violates HTTP
WARNING: use of 'reload-into-ims' in 'refresh_pattern' violates HTTP
WARNING: use of 'ignore-no-cache' in 'refresh_pattern' violates HTTP
WARNING: use of 'ignore-private' in 'refresh_pattern' violates HTTP

Im looking how to fix it. I wonder if can i install the new squid
version without fix those warnings.

Positive Vibrations.

On 03/10/2013 10:53 PM, Amos Jeffries wrote:
> On 4/10/2013 11:59 a.m., IT Support wrote:
>> Hi brothers.
>>
>> Im running Squid Cache: Version 3.0.STABLE8 over debian 6, and Id
>> like to get information about what is the advantage to update it to
>> squid3.1 to the latest vertsion and how can I achieve this mission.
>> How to upgrade squid with out of loss of my old configuration?
>>
>> Please somebody can throw me a bone here?
>
> Dont worry. Squid are designed to be as backward compatible as we can
> code with squid.conf. There is a bit of trouble crossing from the 2.7
> fork to versions older than 3.2, but from 3.0 to later 3.x you should
> not have much problems.
> To be sure you can run "squid -k parse" and get a report of the
> upgrade changes that need to be done. Anythign marked FATAL or ERROR
> is mandatory to change before the new version will rune. The
> WARNING's, UPGRADE, NOTICE are good to fix but can wait until you are
> happy with the new versions operation (although I may point out some
> of those WARNINGS will be about behaviour you may want to change).
>
>
> The advantages of updating are listed in the later versions ChangeLog.
> All the lines starting "Bug ...", far better performance (the latest
> few series average around 20-40% req/sec faster than 3.0 did), and far
> better HTTP/1.1 support.
> Debian security team have done a good job of back-porting the security
> advisory fixes to their older packages. But those are the *only* fixes
> backported and even so there are several major vulnerabilities which
> are unable to be backported due to the wide scale of change necessary
> to fix.
>
> I'm not certain the later versions build properly on Debian 6 any
> more. There are minimum compiler and toolchain requirements for 3.3+
> which that Debian version does not meet. Ubuntu's previous LTE release
> already hit these same problems badly. You could give it a try, but
> don't be surprised if it fails to compile.
>
>
> You can try to install the newer packages and their dependencies out
> of the current Debian stable repositories (Debian 7 / Wheezy).
>
> The basic process is:
> * alter /etc/apt/sources.list changing the repository name to "wheezy"
> or "stable"
> * aptitude update
> * aptitude install squid3
> * undo the changes to sources.list
> * aptitude update
>
> That should get you onto 3.1.20. NP, that 3.1 version has a few very
> annoying IPv6 bugs but if you are happy to cope with them it should
> work fine.
>
> And it is not possible to install the unstable 3.3 version package on
> Debian 6 for the similar reasons as compiling. It pulls in far too
> many dependency packages with newer versions than 6 software plays
> nicely with.
>
>
> PS. As a fellow Debian administrator / user I suggest you may want to
> try out their current stable version. The release team seem to have
> done a stellar job of ensuring stability and for me at least a lot of
> the software there has turned out to be much more reliable than 6 was.
> Also, you can back-port some things like Squid 3.3 from the sid
> repository quite easily still using the same method as above.
>
> Amos
Received on Fri Oct 04 2013 - 15:38:52 MDT

This archive was generated by hypermail 2.2.0 : Fri Oct 04 2013 - 12:00:06 MDT